Polyglot Plugin

Polyglot is next Wordpress plug-in I want to tell you about. You maybe already has notice this flags at the post caption. As you may think this is translation of this post. Such translations are possible with polyglot Plug-in.

The Plug-In homepage has an installation instruction, read it before begin with installations. Actual you need to copy polyglot to your Wordpress installation and then put something like this

<?php if(functionexists('polyglotother_langs')) { //display existing language versions of the post polyglot_other_langs(' ','<ul>', '</ul>', '<li>', '</li>');  
}?>

in your template for enabling the flags. Also look in the PHP file of the plug-in, there is a lot of configuration options, which allows you fine tun of Plug-in.

All in one such kind of Plug-in setup is not a problem for one singular blog, but can get you tired when you have to administrate several Wordpress installations. May be a will write some upgrade to Polyglot in the future that covers such issues.


Update Dez 2015: Multilangual blogging was not good idea. It doubles or tripples your work, but also the blog platform are not really designed for it, so everytime something breaks.. Don't do it.